Skip to content

Exchange 2013 Installation Challenge

by on October 2, 2012

Being an Exchange guy, I thought it was time to download the beta release of Exchange 2013 to take a look under the covers. I spun up a Windows Server 2012 virtual machine. (What? Did you think I would take the easy way out and install it on Windows 2008?) I fired off the installation program, selected both roles (Mailbox and Client Access), and, like Exchange 2010, made sure the checkbox to install all the required components was selected. The installation program finished and I was on my way.

I logged into OWA using the admin account without issue. OWA, as you might expect, looks similar to the Office 2013 preview of Outlook.

One of the items I was most interested in was the Exchange Admin Center, which is the new web-based management console for Exchange. This has replaced the Exchange Management Console used in Exchange 2010 and Exchange 2007. You access it by appending \ecp to the end on the server URL. This URL should be familiar to Exchange 2010 users since this extension was introduced in that version and was known as the Exchange Control Panel.

After I logged in, I hit a brick wall and was presented with the following error message:

Ok. No worries. The error message told me I needed to log on to Exchange Admin Center from the Exchange Server to see more detail. No problem. I launched Server Manager (which has undergone a major facelift in Windows 2012) and turned off IE Enhanced Security.

Now I was ready to see the new Exchange Management interface. I started IE, entered the URL, logged in, and got this:

What? Could not load type ‘Microsoft.Exchange.Management.Security.AdsfFederationAuthModule’? Now what? It turns out the checkbox telling the Exchange installation program to Automatically install Windows Server roles and features required for Exchange does not really do that. (Ok, this is still in beta). To fix this, all you need to do is add the Windows Identity Foundation 3.5 feature and all will be well.

After installing the feature and rebooting. I finally got what I was looking for:

Now, I can write the blog post I intended to: A quick peak at Exchange 2013. Stay tuned…

Comments are closed.

%d bloggers like this: